WordPress 5.5 Güncelleme Sonrası Sitem Çalışmıyor!
WordPress

Binlerce Site WordPress 5.5 Sürümündeki Hata ile Karşılaştı!

Merhaba arkadaşlar, bu yazımda size WordPress 5.5 sürümündeki binlerce siteyi etkileyen hatayı nasıl çözdüğümü anlatacağım. WordPress’in yeni güncelleme sonrası alınan hatanın sebebi Jquery Migtare olduğu tespit edildi. Hata, Jquery Migrate desteğinin bu sürümde kaldırılmasından kaynaklanıyor. Eğer sizde hatalar, kritik bir hata oluştu, güncelleme sonrası site çökmesi gibi problemler yaşıyorsanız sizin için yazdığım bu yazıyı okuyabilir, sorununuzu çözebilirsiniz.

WordPress 5.5 Güncelleme Sonrası Sitem Çalışmıyor!

WordPress 5.5 Güncellemesiyle Gelen Hatanın Çözümü

Ücretli veya ücretsiz kullanmış olduğunuz bir çok tema ve WPBakery Builder, Elementor gibi pluginler’in WordPress 5.5 güncellemesiyle beraber hatalar ortaya çıktı. Bunun sebebi ise yeni gelen wp 5.5 versiyonunda Jquery Migrate desteğinin bu sürümde kaldırılmasından kaynaklanıyor.

Binlerce Site WordPress 5.5 Sürümündeki Hata ile Karşılaştı!

Öncelikle bu konuda yalnız olmadığınızı bilmeniz gerekiyor. Siz ve benim gibi bir sürü WordPress kullanıcısı aynı sorunu yaşadı. Bu durum  JQuery sorunları ile alakalıdır. Yapmanız gereken tek şey WordPress’in bu sorunu yaşayanlar için yayınlamış olduğu “Jquery Migrate” eklentisini kurarak çözmek olacaktır. Eklenti yayınlandıktan sonra 80.000 kişinin eklentiyi kurması bu sorunun ne kadar büyük olduğunu göstermektedir.

WP 5.5 güncellemenin gelmesiyle beraber yaptığım testlerde site hızlarında 1 saniye daha hızlı açıldığını tespit ettim. Bizzat site adresimi hız testi aracına girip öncesi-sonrası olarak karşılaştırdım. Diğer taraftan ise yönettiğim tüm siteleri WordPress 5.5 güncelleme sonrası bozulduğunu farkettim. (WPBakery Page Builder, Elementor ve Visual Composer) eklentisini kullandığım internet sitelerimi yazı, resim ve video ekleyemediğimi anlayınca ortada bir sıkıntı olduğunu anladım.

Enable jQuery Migrate Helper

WordPress 5.5 Tema Düzenleme Hatası

Güncelleme, WordPress 5.5 sürümlerini indiren bütün sitelerde farklı özelliklerde hatalar vermektedir. Sebebi ise eski WordPress temalarının 5.5 için uyumlu olmaması. Güncel temalarda genelde bir sorun çıkmadığını ama yine kontrol yapmanız gerektiğini hatırlatayım.

Tema düzenleme hatası, WpBakery Page Builder, Elementor, Visual Composer vb. tema düzenleme pluginlerinin sayfa düzenlenmesi sırasında verdiği hatadır. Sayfa düzenlerken “Ajax Url tanımlanmadı hatası” alınır. Yada sürükle bırak tarzı eklentilerin hiçbir fonksiyonu düzgün çalışmaz.

Bu hatayı yukarda bahsettiğim gibi “Enable jQuery Migrate Helper” eklentisiyle bir kaç dakikada çözebiliriz.

WordPress  Wp Admin Beyaz Sayfa Sorunu

WordPresste eğer beyaz ekran hatası alıyorsanız bunun sebebi kurmuş olduğunuz eklenti olabilir. Bu sorunu çözebilmek adına Ftp programına erişip plugin dosyasının adını değiştirerek eklentileri tek tek pasif etmek toplu bir şekilde devre dışı bırakmış oluruz.

Gelin beraber bu işlemi uygulayalım:

  • İlk öncelikle filezilla programı ve cpanelimizdeki dosya yönetisi ile WordPress çekirdek dosyalarımıza (wp-admin, wp-content, wp-includes klasörlerinin olduğu klasöre) erişim sağlıyoruz.
  • Bir sonraki adım ise wp-content dosyasının içerisine girmek olacaktır.
  • Wp content dosyasından sonra plugins dosyasının adını değiştirmeniz, eklentileri devre dışı bırakmanız konusunda yardımcı olacaktır.

jQuery Migrate Eklentisi Nasıl Kurulur?

WordPress admin paneline girdikten sonra Eklentiler>Yeni ekle> Enable jQuery Migrate Helper arama yerine arattıktan sonra eklentiyi kurup aktif ediyoruz.

WordPress 5.5 Sürümü Nasıl İptal Edilir?

  1. WordPress admin paneline giriş yapın.
  2. Eklentiler > Yeni eklenti ekle kısmına WP Downgrade yazın
  3. Karşınıza çıkan WP Downgrade eklentisini kurup aktif ediniz.
  4. Eklentiyi aktif ettikten sonra ayarlar kısmına girip “WordPress Target Version” kısmında bir önceki versiyon olan 5.4.2’ e çevirebilirsiniz.
  5. Ardından değişiklikleri kaydedip WordPress 5.5 olan sürümünüzü 5.4’ e çevirmiş olacaksınız.
  6. İşlem tamam

WP Downgrade | Specific Core Version

Not: Bu işlemleri yapmadan önce sitenizin mutlaka yedeğini almanızı öneririm. WP Downgrade’de 5.4 yerine 5.4.2 yazmaları en azından 5.4’de olan açıkların sömürülememesine sebep olacaktır. r10’daki arkadaşımın tavsiyesi üzerine bu notu ekledim.

Bu güncelleme iyi mi oldu yoksa tam bir felaket mi?. Yorumlarda konuşalım.